Airmail for iPhone

Default e-mail per Acount

It will be good to choose a default email alias per Acount and not a default e-mail for all acount

45 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Xav shared this idea  ·   ·  Admin →

6 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Jamie commented  · 

    This is the only reason I'm not using the iOS app the moment. All my send form addresses are alias for websites I own but where I use gmail to manage email. It's not an iOS limitation as other email apps (Spark, Newton mail etc) do it just fine. Hopefully this get released in the next update

  • Hank commented  · 

    Yes, using iOS I really want to have different default sender and reply-to email addresses, depending on which gmail account I received the email from. I use two gmail accounts. For one of them, when I reply I want it to clearly come from the same gmail account. For the other, when I reply I want to use the alias that I use for most email. On a Mac this is how airmail already works.

    I saw this feature request marked as accepted, and I also saw someone wrote that it is an OS limitation. Could you make that clearer? Is this something in the queue of things to be worked on, or not?

  • Anonymous commented  · 

    I would love this. I've got a Gmail account that doesn't have any aliases but I always use my iCloud account with an alias (and never the regular login email). I would love the ability to always send email with that alias JUST for that particular account (and not an app-wide setting). I'm putting in my vote for account-specific default aliases.

  • Pudding commented  · 

    I would be even happier if we had an option that would allow us force all replies (to emails received through an account) to default to our chosen alias!

  • Jordan commented  · 

    I agree, it would great. In my case, per every gmail account I have connected, id prefer to have an alias email set as the default sending email for the account in which its nested under instead of my @gmail address.

Feedback and Knowledge Base